awips2/rpms/python.site-packages/Installer.cherrypy/component.spec
2016-04-21 13:42:45 -05:00

70 lines
1.5 KiB
RPMSpec

# Turn off the brp-python-bytecompile script
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
%define _build_arch %(uname -i)
#
# AWIPS II Python cherrypy Site-Package Spec File
#
Name: awips2-python-cherrypy
Summary: AWIPS II Python cherrypy Site-Package
Version: 3.1.2
Release: 3
Group: AWIPSII
BuildRoot: %{_build_root}
BuildArch: noarch
URL: N/A
License: N/A
Distribution: N/A
Vendor: Unidata
Packager: Michael James
AutoReq: no
requires: awips2-python
provides: awips2-python-cherrypy
%description
AWIPS II Python cherrypy Site-Package - Installs the AWIPS II Python
cherrypy Site-Package in the Python installation.
%prep
# Verify That The User Has Specified A BuildRoot.
if [ "%{_build_root}" = "" ]
then
echo "A Build Root has not been specified."
echo "Unable To Continue ... Terminating"
exit 1
fi
rm -rf %{_build_root}
mkdir -p %{_build_root}
if [ $? -ne 0 ]; then
exit 1
fi
%build
SITE_PACKAGE_SRC_DIR="pythonPackages/cherrypy"
cd %{_baseline_workspace}/${SITE_PACKAGE_SRC_DIR}
/awips2/python/bin/python setup.py build
%install
SITE_PACKAGE_SRC_DIR="pythonPackages/cherrypy"
cd %{_baseline_workspace}/${SITE_PACKAGE_SRC_DIR}
/awips2/python/bin/python setup.py install --root=%{_build_root} \
--prefix=/awips2/python
%pre
%post
%preun
%postun
%files
%defattr(644,awips,fxalpha,755)
/awips2/python/lib/python2.7/site-packages/*
%defattr(755,awips,fxalpha,755)
/awips2/python/bin/*