Former-commit-id:7fbf0bf1db
[formerly814c3f8147
] [formerly aeebdfe79cf10745d8b4dc2fd8f9ec714f2a12fa [formerly2b35f99b04
]] Former-commit-id: 62d141eb76debb459cc1d8e8483d6f71ba099d41 [formerly692f72d9c9
] Former-commit-id:e4267c31d4
62 lines
1.2 KiB
RPMSpec
62 lines
1.2 KiB
RPMSpec
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
|
|
%define _build_arch %(uname -i)
|
|
%define _python_pkgs_dir "%{_baseline_workspace}/pythonPackages"
|
|
|
|
#
|
|
# AWIPS II Python thrift Spec File
|
|
#
|
|
Name: awips2-python-thrift
|
|
Summary: AWIPS II Python thrift Distribution
|
|
Version: 20080411p1
|
|
Release: 3
|
|
Group: AWIPSII
|
|
BuildRoot: %{_build_root}
|
|
BuildArch: noarch
|
|
URL: N/A
|
|
License: N/A
|
|
Distribution: N/A
|
|
Vendor: Raytheon
|
|
Packager: Bryan Kowal
|
|
|
|
AutoReq: no
|
|
requires: awips2-python
|
|
provides: awips2-python-thrift
|
|
|
|
%description
|
|
AWIPS II Python thrift Site-Package
|
|
|
|
%prep
|
|
# Verify That The User Has Specified A BuildRoot.
|
|
if [ "%{_build_root}" = "" ]
|
|
then
|
|
echo "A Build Root has not been specified."
|
|
echo "Unable To Continue ... Terminating"
|
|
exit 1
|
|
fi
|
|
|
|
rm -rf %{_build_root}
|
|
|
|
%build
|
|
|
|
%install
|
|
THRIFT_SRC_DIR="%{_python_pkgs_dir}/thrift"
|
|
|
|
mkdir -p %{_build_root}/awips2/python/lib/python2.7/site-packages/thrift
|
|
cp -rv ${THRIFT_SRC_DIR}/* \
|
|
%{_build_root}/awips2/python/lib/python2.7/site-packages/thrift
|
|
|
|
%pre
|
|
|
|
%post
|
|
|
|
%preun
|
|
|
|
%postun
|
|
|
|
%clean
|
|
rm -rf %{_build_root}
|
|
|
|
%files
|
|
%defattr(644,awips,fxalpha,755)
|
|
%dir /awips2/python/lib/python2.7/site-packages
|
|
/awips2/python/lib/python2.7/site-packages/*
|