89 lines
1.9 KiB
RPMSpec
89 lines
1.9 KiB
RPMSpec
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
|
|
%define _build_arch %(uname -i)
|
|
%define _python_pkgs_dir "%{_baseline_workspace}/pythonPackages"
|
|
%define _python_build_loc %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
|
|
#
|
|
# AWIPS II Python awips Spec File
|
|
#
|
|
Name: awips2-python-awips
|
|
Summary: AWIPS II Python awips Distribution
|
|
Version: 0.9.3
|
|
Release: 3
|
|
Group: AWIPSII
|
|
BuildRoot: %{_build_root}
|
|
BuildArch: %{_build_arch}
|
|
URL: N/A
|
|
License: N/A
|
|
Distribution: N/A
|
|
Vendor: Unidata
|
|
Packager: Michael James
|
|
|
|
AutoReq: no
|
|
requires: awips2-python
|
|
Obsoletes: awips2-python-ufpy < 15.1.3-1
|
|
Obsoletes: awips2-python-dynamicserialize < 15.1.3-1
|
|
Obsoletes: awips2-python-thrift < 20080411p1-4
|
|
provides: awips2-python-awips
|
|
|
|
%description
|
|
AWIPS II Python Awips Site-Package
|
|
|
|
%prep
|
|
# Verify That The User Has Specified A BuildRoot.
|
|
if [ "%{_build_root}" = "" ]
|
|
then
|
|
echo "A Build Root has not been specified."
|
|
echo "Unable To Continue ... Terminating"
|
|
exit 1
|
|
fi
|
|
|
|
rm -rf %{_build_root}
|
|
mkdir -p %{_build_root}
|
|
if [ -d %{_python_build_loc} ]; then
|
|
rm -rf %{_python_build_loc}
|
|
fi
|
|
mkdir -p %{_python_build_loc}
|
|
|
|
%build
|
|
AWIPS_SRC_DIR="%{_python_pkgs_dir}/python-awips"
|
|
|
|
cp -rv ${AWIPS_SRC_DIR}/* \
|
|
%{_python_build_loc}
|
|
RC=$?
|
|
if [ ${RC} -ne 0 ]; then
|
|
exit 1
|
|
fi
|
|
|
|
pushd . > /dev/null
|
|
cd %{_python_build_loc}
|
|
export LD_LIBRARY_PATH=/awips2/python/lib
|
|
/awips2/python/bin/python setup.py build
|
|
RC=$?
|
|
if [ ${RC} -ne 0 ]; then
|
|
exit 1
|
|
fi
|
|
popd > /dev/null
|
|
|
|
%install
|
|
|
|
pushd . > /dev/null
|
|
cd %{_python_build_loc}
|
|
export LD_LIBRARY_PATH=/awips2/python/lib
|
|
/awips2/python/bin/python setup.py install \
|
|
--root=%{_build_root} \
|
|
--prefix=/awips2/python
|
|
RC=$?
|
|
if [ ${RC} -ne 0 ]; then
|
|
exit 1
|
|
fi
|
|
popd > /dev/null
|
|
|
|
%clean
|
|
rm -rf %{_build_root}
|
|
rm -rf %{_python_build_loc}
|
|
|
|
%files
|
|
%defattr(644,awips,fxalpha,755)
|
|
%dir /awips2/python/lib/python2.7/site-packages
|
|
/awips2/python/lib/python2.7/site-packages/*
|