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Acronyms and Abbreviations Used in This Document

AWIPS Development Environment ADE
Advance Weather Interactive Processing System AWIPS
Common AWIPS Visualization Environment CAVE
Configuration Management CM
Database DB
Deficiency Report/Change Request DR
Enterprise Data EXchange EDEX
Enterprise Service Bus ESB
Forecaster Integration Testing FIT
Free & Open Source Software FOSS

Hierarchical Data Format 5-multi-object file format for the transfer of ~ HDF5
graphical and numerical data between computers

Hypertext Transfer Protocol HTTP
Yellowdog Updater, Modified YUM
Java Development Kit JDK
Java Runtime Environment JRE
Local Data Manager-a collection of cooperating programs that select, LDM
capture, manage, and distribute arbitrary data products

Process ID PID
Postgres Structured Query Language-FOSS database software PostgreSQL
Open Source AMQP Messaging Qpid
Round 1 Group 1 R1G1
Red Hat Package Manager RPM
Snap Up (Delivery after TO11 Slice 6) SU
Task Order TO
Topographical directory/files TOPO
Visualization Viz
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1. Introduction

In order to perform many actions in this document, it is necessary to have root access or sudo
privileges to access root. This Flow Tag document provides instructions for installing and setting
up the AWIPS Il AWIPS Development Environment (ADE). The procedures are comprehensive,
enabling an engineer to conduct the setup with very little background.

2. Document Conventions

The flow tag steps are presented in outline format. All steps utilize the following typographic
conventions:

A square box indicates a step to be accomplished. Example:
e  Stop All Services:
A circle indicates a checkpoint for the step. Example:
0 Stop Camel:
Bold font indicates keystrokes, button clicks, notes of interest, etc. Example:
./edex _camel stop

Bold italic blue font indicates something that needs to be updated to the current value (machine
name, date, etc.). Example:

* rm -rf /home/user/caveData

Commands in parentheses are example commands based on the Omaha AWIPS Il Testbed
Configuration.

* mount edex-machine:/awips2/edex/opt/data/hdf5 /test-
data (mount awips-devl:/awips2/edex/opt/data/hdf5 /test-data)

3. AWIPS Integration Deployment Instructions

To make things faster and more accessible for multiple deployments, you may want to copy the
files from the delivery media to a network location.

For the purposes of this document we will use [path to installers] in place of this location.

For example, usually the path to the delivery files for the OMAHA AWIPS Integration
deployment is /awipscm/AWIPSDVDs/AWIPS XXX _Installers (where the XXX is the
Release/Build name/number).

3.1 Deploy the ADE
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3.1.1 Test Your Graphics Card (Required for CAVE Development)
QA ENG

To run and debug CAVE, you must have a CAVE-capable graphics card. This is not needed if
you will only be running and debugging EDEX.

e Test your graphics card (commands may vary based on your graphics card and the driver
installed).
= Save everything and close all applications. If your graphics card or
driver is not correct, your XWindows may crash.
= Open aterminal if you do not already have one.
glxinfo | grep OpenGL
e Make sure there are no errors and that your XWindows does not
crash.
e Make sure that the OpenGL version string is 2.0 or higher.
* glxgears
e You should see an animation of a set of gears.
= If neither glxinfo nor glxgears is available, you can try to open CAVE via
Eclipse. (Note: Section 3.1.8 provides instructions on How to Run/Debug
CAVE, but you will need to run through all the sections before the debug
CAVE section.)
= If you get any errors, if CAVE crashes, or if your XWindows crashes, try
installing the latest driver for your graphics card.
= Otherwise, you may need a CAVE-capable graphics card—one that
supports OpenGL version 2.0 (or higher).

3.1.2 Stop and Uninstall EDEX, CAVE, and/or the ADE (if already installed) for
Releases 1-7.3 and Later

QA  ENG

Note: Root permissions are required to uninstall the ADE RPMs. Login as the root user or use
sudo as in the examples.

Q Uninstall any previously installed AWIPS Il Software.
e First, stop any EDEX Services (Idm, camel, gpid, postgres, and httpd-pypies),
close CAVE, and/or close Eclipse.

° Stop EDEX (all running instances)
Select the terminal where EDEX is running.
= Press Ctrl+C.
= If EDEX was started via service command, run service edex_camel stop
as user root or via sudo to stop camel processes.
= Ensure all camel processes are stopped by grepping for the wrappers &
java.
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* ps uax | grep wrapper then ps aux | grep java

= Use kill to kill any PID other than the grep process.
Note: If you kill java wait a moment and repeat the ps command
as the wrapper may automatically restart.

e Stop Qpid.
= As user root run service gpidd stop
= Ensure all Qpid processes are stopped by typing service qpidd status or
grepping for the gpid daemon
= ps aux | grep gpidd
= Use kill to kill any pid other than the grep process
° Stop Httpd-Pypies.
Select the terminal where Httpd-Pypies is running and stop by running the
service stop command
= /sbin/service httpd-pypies stop
= Ensure all httpd-pypies processes are stopped by grepping for them
= ps aux | grep httpd
= Use kill to kill any PID other than the grep process.
° Stop Postgres.
Select the terminal where Postgres is running.
= Press Ctrl+C.
= Ensure Postgres is stopped by grepping for postmaster
* ps aux | grep postmaster
= Use kill to kill any pid other than the grep process

o Unpack the rpms:
e cd /home/user/
e tar xvf <Path-to-ade-tar-file>/awips2-ade-*.tar

Note: When you remove the ADE RPMs, other installed EDEX Services will be removed as
well due to dependencies between components.

e _ Uninstall the RPMs:
* sudo <Path-to-ade-tar-file>/ade quick uninstall.sh
e  Verifythat all AWIPS Il components have been removed.
= rpm-qa|grep awips2
e  Manually remove any AWIPS Il components that remain (if any remain).
= sudo yum remove awips2-\* -y
e Remove the root installation directory.
= sudo rm -rf /Jawips2/
e  Remove old source code (replace user with your username)

* rm -rf /home/user/awips

3.1.3 Install the ADE RPMs and the Standalone Development Environment
QA ENG
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Note:

Note:

Note:

Root permissions are required to install the ADE RPMs. Login as the root user or use
sudo as in the examples. The sudo user should see an 'ADE_Eclipse' launch icon on the
Desktop after the installation.

EDEX requires approximately 6 GB of space.

Unpack the rpms (if not done already):

e cd /home/user/
e tar xvf <Path-to-ade-tar-file>/awips2-ade-*.tar

Create the awips user (if not done already):

® sudo useradd awips

Create the fxalpha group (if not done already):

e sudo groupadd fxalpha

Add the fxalpha group to the awips user (if not done already):

® sudo usermod -a -G fxalpha awips

cd into the directory just untar'd and run the install script:

cd awips2-ade-*

sudo <Path-to-ade-directory>/ade quick_install.sh

Note: Ensure ade_quick_install.sh has executable permissions by typing
chmod +x <path-to-ade-directory>/ade_quick_install.sh. This might
need to be done as user root.

At this point, you may want to re-install the Standalone Development environment. The
following commands assume the user has obtained the necessary rpms for the desired
Standalone build and configured the YUM repository for said rpms. To re-install, run the
following commands as user root or via sudo:

yum groupremove “AWIPS II Standalone”
yum groupinstall “AWIPS II Standalone”

o Note: If installing underlying 14.4.1 standalone code, the postgres

database will need to be upgraded to version 9.3.5 prior to the group
install. The necessary scripts (initialize_database.sh,
postgresql_post_upgrade.sh, run_postgis_upgrade.sh, settings.sh) can be
obtained from CM or Environment teams and placed into the following
folder on the developer workstation:
/data/fxa/INSTALL/awips2/scripts/postgresql9.3-upgrade (this directory
will need to be created if it does not already exist). After ensuring the
awips2-maps-database package is not installed (rpm —q awips2-maps-
database command returns nothing), execute the initialize_database.sh
followed by the postgresql_post_upgrade.sh scripts while ignoring errors
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about restoring databases. Ensure postgres has been updated (psql —
version command should output version 9.3.5).

o Note: If errors are received during the groupinstall that refer to missing
dependencies, you will probably need to ensure log4j.x86_64 and
z1ib.i686 are installed by issuing the following as root: yum install
log4j.x86_64 zlib.i686

o Note: Ensure that the AWIPS2 repository contains wxGTK-<version>.el6,
and NOT wxGTK-<version>.el6.centos. The centos version of this
package is flagged as an unacceptable dependency during installation.

o Note: If errors are received during groupinstall that refer to conflicts with
the awips2-python-pillow package, an exclude statement will need to be
added to the groupinstall command: yum groupinstall "AWIPS II
Standalone --exclude=awips2-python-pillow

3.1.4 Install the AWIPS Il ADE source
QA ENG

Note: Login as a development user
Note: The ADE requires approximately 4 GB of space.

e  Unpack the source jar
e cd /home/user/
e /awips2/java/bin/jar -xvf  <path-to-ade-directory>/awips2-
ade-baseline-SOURCES. jar

3.1.5 Update Postgres Database Roles and Permissions
QA ENG

Note: As a result of security changes in 16.4.1, database access is being limited for user ‘awips'
and a new user, ‘awipsadmin’, is being added for administrative database tasks. A delta script,
alter_database_roles_and_permissions.sh, will need to be run in order to enact these changes on
your developer machine any time an older database (older than 16.4.1) is imported.
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e _ Runpostgres upgrade scripts. Ensure postgres is not running prior to running
scripts. These scripts will be contained within the 17.1.1 repo tarball
(/data/fxa/INSTALL/awips2/scripts/postgresql-9.5.3-upgrade/)

¢ vyum downgrade awips2-database-server-configuration awips2-
postgresql awips2-psql awips2-cli

¢ cd <path-to-directory-with-postgres-upgrade-scripts>

e ./postgres_pre upgrade.sh

e sudo yum upgrade awips2-postgresql awips2-psql

e ./postgres_post _upgrade.sh

e ./upgrade postgis.sh

e ./rebuild stats.sh

e sudo yum upgrade awips2-database-server-configuration
awips2-cli

Note: SSL/Certificate-based authentication changes made in 17.1.1 within postgresgl.conf and
pg_hba.conf are not necessary within the ADE environment.

Note: The aforementioned steps assumes that your local user has database access, otherwise the
alter_database_roles_and_permissions.sh script will need to be run as a user on your machine
that has database privileges.

3.1.6 Perform Utility Tree File Migration
QA ENG

. __ Rundelta scripts
e Find delta scripts preUpgradeMoveL ocalizationFiles.sh &
movelLocalizationFiles.sh from 17.1.1 repository tarball
(/data/fxa/INSTALL/awips2/scripts/deltaScripts/) and run as local user with sudo
privileges
® . /preUpgradeMovelocalizationFiles.sh
® . /movelocalizationFiles.sh

3.1.7 Set Up the AWIPS Il ADE
QA  ENG

e  Setup Eclipse.
e Open Eclipse.
=  Command line
e /awips2/eclipse/eclipse.sh
o This file script sets up the environment variables needed for
debugging AWIPS EDEX/CAVE and calls eclipse with the
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correct command line arguments to give it more memory.
e Set /home/user/awips as the Workspace. (where the ADE source jar was
unpacked)
e (o to the Workbench.
e Set your Java version
= Select Window->Preferences
= Expand Java, then select Installed JREs
= Verify that /awips2/java is listed and it has a check mark next to it
(checked as default). If not do the following:
e Click Add...
Select Standard VM.
e Click Directory next to JRE home:
Select /awips2/java and click OK.
e Click Finish.
e Verify the Java Compliance Level.
= With Java expanded, select Compiler
= Inthe JDK Compliance box at the top, verify that 1.7 is selected in the
Compiler compliance level dropdown (you may have to scroll over it to
see the dropdown). If it is set to a lower version, you may get a lot of
compiler errors.
e Set your Ant version.
= In the Preferences dialog, expand Ant and select Runtime
= Click the Ant Home... button
= Select (filesystem) /awips2/ant
= Click OK (just to close the browse window; if you click the OK to
save/close Preferences, you will need to re-open Preferences for the next
step)
e Set your Pydev Interpreter.
= In the Preferences dialog, expand Pydev, then expand Interpreters and
select Python Interpreter
= Click the New... button in the Python interpreters section (at the top of
the dialog).
= Browse to and select (filesystem) /awips2/python/bin/python and click
OK (to close the Browse dialog).
= On the Selection Needed popup, keep the default selections and click OK.
= Click OK (save and close Preferences).
= If you get a popup asking you if you want to build because your compiler
settings have changed, click the No button. This will be done a few steps
later.
e Disable Build Automatically (temporarily until everything is set up)
= Select Project, and then deselect Build Automatically.
e Disable API Errors
= Select Window->Preferences
= Expand Plug-in Development
= Select API Baselines
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= Look for Missing API baseline: within the Options box
= Make sure this is set to Ignore
e Set up your Eclipse Projects.

= Select File->Import.

= Inthe Import dialog, select General->Existing Projects into
Workspace.

= Click Next.

= Click the Browse button next to Select root directory edit box.

= Select awips (should be the default directory) and click OK.
It should find all the projects for each directory — they should all be
selected.

= Click Finish.

e Set up the CAVE configuration folders in the eclipse directory.
= Open a terminal window if not already open
= cd /awips2/eclipse (if not already there)
sudo In  —s/home/user/awips/build/static/common/cave/etc
(Link the etc directory in your eclipse directory.)

e ____ Compile AWIPS II.

= Open Eclipse if not already open (with the /home/user/awips workspace).

= Select Project->Clean.

= Make sure the Clean all projects radio button, the Start a build
immediately checkbox, and the Build the entire workspace radio button
are selected, and click OK.

= This will clean and build all the projects. At the bottom of the eclipse
window, the status bar will indicate how far the build is. Wait until it
reaches 100% -- the percentage progress will disappear.

= Select the Problems tab at the bottom of the Eclipse window and make
sure there are no Errors. Warnings are okay.

= Note: Errors such as:

Project 'com.raytheon.edex" is missing required library:
‘client-plugin-airep.jar’

OR

Bundle ‘com.facebook.thrift’ cannot be resolved from
com.raytheon.uf.common.serialization

may be due to a glitch in Eclipse. Try moving the .classpath file in
com.raytheon.edex to a subfolder, rebuild, move it back, then build again.

e Select Window->Show View->Navigator.

e In the Navigator view, expand com.raytheon.edex.

e Leftclick on .classpath and drag it into the META-INF folder
(Any folder would work except for one that already contains a
.Classpath file.)

e Select Project->Clean. Then click OK and wait for it to finish
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building. You will probably get a Build Failed message, but at
times you will not get any errors when there should be — because
the .classpath file is no longer in the right place.

e Leftclick on .classpath in the META-INF folder and drag it back
to the com.raytheon.edex folder.

e Select Project->Clean. Then click OK, and wait for it to finish
building.

e You should no longer see errors in the Problems tab, only
Warnings.

Note: Errors such as:

“A cycle was detected in the build path...”

Close plug-in "ohd.hseb.common”.

Select Project->Clean.

Open the “ohd.hseb.common” project.

Select Project->Clean.

Note: Errors of type “C/C++ Problem” can usually be resolved by
removing C/C++ code from the Workbench:

e From the Package Explorer window to the left choose all
packages with names beginning with “rary” as well as
“com.raytheon.uf.nativelib”, right-click and select “Delete.”

e Select Project -> Clean again to clean and rebuild.

e Alternatively, when importing the project above, the rary and

nativelib packages can be deselected prior to importing

e Re-enable Build Automatically.

Select Project. Then select Build Automatically.

o Set up EDEX deploy.
e In Eclipse, make sure the Java - Navigator perspective is selected.

If the Navigator tab is not available (Package Explorer and Hierarchy are
available by default):
e Make sure the Java Perspective is selected.
o IfJavais not selected, click the >> button in the upper right
corner and select Java.
e Select Navigate->Show In->Navigator.

e May need to set ownerships and permissions:

0 sudo chown user:fxalpha -R /awips?2
sudo chmod 775 -R /awips?2
sudo chmod 700 -R /awips2/data

e Expand build.edex.

Right click on deploy-install.xml and select Run As->2 Ant Build... (not
1 Ant Build).
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e In the Edit configuration and launch dialog:
= Inthe Targets tab make sure that main [default] is selected.
= Click Apply to save any changes.
= Click Run to deploy EDEX.

e If you get a message “/home/<Your Home
Directory>/awips/build.edex/deploy-install.xml:556: Execute failed:
java.io.IOException: Cannot run program "chmod": java.io.IOException:
error=7, Argument list too long”

= Edit the deploy-install.xml file as follows:

<!-- Change permissions on the Linux start file -->
<chmod file="${esbDir}/bin/start.sh" perm="ugo+rx" />
<chmod file="${esbDir}/bin/linux-x86-32/wrapper"
perm="ugo+rx" />
<chmod dir="${esbDir}/data"™ perm="775"
includes="**/*" yerbose="true" type="both"
parallel="false"/>

e If you get an error like this:
Fatal Python error: Interpreter not initialized (version mismatch?)

Then you need to, after right-clicking deploy-install.xml and selecting Run as 2
Ant Build, go to the Main tab and within the Arguments box near the middle of
the Edit Configuration window, type the following:

-Darchitecture=x86_64

Then stop all processes, clear your project, rebuild your workspace, and try again.

3.1.8 How to Run/Debug EDEX in the ADE
QA ENG

Q _ Deploy EDEX (if you have not already done so, since the last code
changef/install).

e Click on the External Tools button from the toolbar (the dropdown arrow next to

a green play icon with a lock) and select build.edex deploy-install.xml.
. Note: The External Tools button will use the last one selected
going forward.

e Note: Each time you Deploy EDEX you will need to shut down and restart
EDEX; if you do not do this, you will not be able to connect to it for
debugging. If you Deploy EDEX without restarting EDEX, you will get
the following error:

Launching EDEX has encountered a problem. Failed to connect
to remote VM. Connection refused.
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° Start the EDEX services.

Note: Currently, there is no way to execute EDEX from
Eclipse; rather, you test run EDEX by starting EDEX in a terminal. The
order of startup is critical, however! For the following instructions, you

can either open multiple terminals or you can open a single terminal and
open multiple tabs within the terminal.

e Start Postgres.

e StartH

Open a terminal.

Change directory to the AWIPS |1 PostgreSQL directory.

cd /awips2/postgresql/bin

Start the development PostgreSQL.

Jstart_developer_postgres.sh

Leave this terminal open. Closing it can leave the process in a bad state.
To shut down Postgres, make sure the terminal window is selected and use
Ctri+C.

ttpd-Pypies.

Open a terminal.

Change directory to the AWIPS Il Httpd-Pypies logs directory (this is not
really a necessary step; however, it will make it easier to verify that httpd
has started correctly).

cd /awips2/httpd_pypies/var/log/httpd

Become root.

sudo su

Edit the httpd.conf file and httpd-pypies script so as to start httpd-pypies
as your user

Change directory to /awips2/httpd_pypies/etc/httpd/conf/

cd /awips2/httpd_pypies/etc/httpd/conf/

Make the following change to httpd.conf: (substitute your username for
user)

User user

Group awips

Change directory to /etc/init.d/

cd /etc/init.d/

Make the following change to httpd-pypies: (substitute your username for
user)

echo -n $"Starting logging service:"

nohup su user -c "$loggingCmd >

/tmp/pypiesLoggingService.log 2>&1" > /dev/null &

Start Httpd-Pypies as user root

/sbin/service httpd-pypies start (If /shin/service does not work, you can
also use: /etc/init.d/httpd-pypies start)

To verify that httpd-pypies started successfully, check the error_log; if
httpd-pypies started successfully, the last line of the error log will be
similar to:

Apache/2.2.3 (CentOS) configured -- resuming normal operations
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17.1.1: AWIPS Flow Tag Instructions: ADE Setup

e StartQ

Leave this terminal open. To stop Httpd-Pypies, use: /sbin/service httpd-
pypies stop (or: /etc/init.d/httpd-pypies stop)

pid.

Open a terminal.

Edit the gpidd script so as to start Qpid as your user

su - (switch to the root user)

cd /etc/init.d/

Edit the gpidd script as follows: (substitute your username for user)

# Who to run QPID as, usually "awips". (NOT "root")
QPIDUSER=user

Start Qpid

As root user or with sudo type service gpidd start
To shut down gpid, type service gpidd stop as root user or with sudo

e Start EDEX.

Open a terminal.

Edit the edex_camel start script so as to start EDEX as your user

su - (Switch to the root user)

cd /etc/init.d/

Make the following change to edex_camel: (substitute your username for
user)

Exit from root user and back to your user by typing Ctri+D

Change directory to the AWIPS Il EDEX directory.

cd /awips2/edex/bin

Start EDEX ingest in debug (omit the -b or type sudo service edex_camel
start ingest if you want to run EDEX ingest without debug).

Jstart.sh -b ingest

It may take a few minutes for EDEX to finish loading. When you get the
following text, EDEX is ready:

*hhhhkhkhkkkhkhkhkhhhhhkhkhkhkkhkhiirhhhkhhkhhhihrrhhhhkhhhiiiiixx

* EDEX ESB is now operational *

*hhkkkhkhkkkhhkhkkhhhkkhhhkhhhkkhkhhkhkkhhkhkkihkhkkihhkhkihhkihhkkihihkhhiikkiiikk

e If you receive outOfMemory errors in the edex-ingest.log, you
may need to set the value for non-root users within
[etc/security/limits.d/90-nproc.conf to 200000.

Leave this terminal open. Closing it can leave the process in a bad state.
To shut down EDEX, make sure the terminal window is selected and use
Ctri+C.
(Optional) Repeat for Start EDEX Ingest Grib and/or Start EDEX
Request
Note: If you accidentally close the terminal window for any of
these processes, stop/kill all leftover processes and restart them in the
proper order.
For EDEX

® ps uax | grep wrapper then ps aux | grep java
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AWIPS Operational Build 17.1.1: AWIPS Flow Tag Instructions: ADE Setup

e Use Kill to kill any PID other than the grep process.
° Note: If you kill java wait a moment and repeat the ps
command as the wrapper may automatically restart.
= For Qpid
® ps aux | grep gpidd
e Use kill to kill any pid other than the grep process
= For Httpd-Pypies
® ps aux | grep httpd
e Use kill to kill any PID other than the grep process.

= For Postgres
® ps aux | grep postmaster
e Use kill to kill any PID other than the grep process.

e  Startthe EDEX Eclipse Debugger.
e If this IS the first time debugging EDEX:
= Open Eclipse if not open already.
= Click Run->Debug Configurations...
= Select Remote Java Application, then select the New launch.
configuration icon in the upper left corner of the window (it looks like a
sheet of paper with a plus sign).
= Set the Name to EDEX.
= Make sure the Project selected is com.raytheon.edex.common.
= Make sure the Host is set to localhost.
= Set the Port to 5006 for ingest
e This process should be repeated to debug other EDEX processes.
Use port 5007 for ingestGrib and 5005 for request.
= Click the Apply button.
= Click the Debug button.
e If thisis NOT the first time Debugging EDEX:
= Click the dropdown arrow next to the Debug button (bug icon) in the
toolbar and select EDEX.
e Set a breakpoint in the code, for example, to debug IndexSrv:
= Set a breakpoint in.
com.raytheon.edex.ingestsrv/src/com/raytheon/edex/services/IndexSrv
Java in the index () method (from the Java Perspective).
e Switch to the Debug Perspective.
= You may get a popup message asking if you want to switch to the Debug
perspective (when starting a Debug session). If you get this message, just
click Yes.
= If this is the first time opening the Debug Perspective, click the Open
Perspective icon (box with a plus sign) in the upper right corner and
select Debug (with a bug icon) from the dropdown menu.
= Otherwise, click Debug (icon with a bug) in the upper right corner.
e Start Debugging
= In order to hit the breakpoint, it needs a file to Ingest. Copy a data file into
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/awips2/edex/data/manual .As soon as the file starts to ingest, the
breakpoint will show up in green.

. Note: The data archive as of DR3 is only used by LDM.
Therefore, if you do not have an LDM running locally, putting data
files in the data archive location (/tmp/sbn, set by the EDEX
installer) will not do anything. Also, deploying EDEX will
overwrite the archiveDir value in environment.xml for both base
and site, resetting it to the default of /tmp/sbn.

= If you get a message Source not found:

e Click the Edit Source Lookup Path... button,

Click the Add... button.

Select File System Directory and click OK.

Click the Browse... button.

Select /nome/user /awips and click OK (close Browse window).

Select the Search subfolders checkbox and click OK (close the

Add File System Directory window).

e Click OK (close the Edit Source Lookup Path window).
= Now you can step through the code.

o Stop the services (when done debugging).
e Stop EDEX (all running instances)
= Select the terminal where EDEX is running.
= Press Ctrl+C.
e Stop Qpid.
= Select the terminal where Qpid is running.
= Press Ctrl+C.
e Stop Httpd-Pypies.
= Select the terminal where Httpd-Pypies is running.
= Stop Httpd-Pypies.
= /sbin/service httpd-pypies stop
e Stop Postgres.
= Select the terminal where Postgres is running.
= Press Ctrl+C.
° Note: The order in which you stop the processes should be the
opposite of the order in which they were started — EDEX instances, Qpid,
Httpd-Pypies, then Postgres.

3.1.9 How to Run/Debug CAVE in the ADE
QA ENG

e  Ifyouareusing alocal EDEX:
= Note: Before starting EDEX (for use with CAVE debugging), you may
want to be sure that there is no —b in the Start EDEX Ingest
shortcut’s command line (see above). It will provide cleaner logs
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and may be faster.
= Start the EDEX Services (Postgres, Httpd-Pypies, Qpid, EDEX Request
required for running CAVE, EDEX Ingest optional, and EDEX Ingest
Grib optional) (see above). Note: You may want to stop and restart the
services if you removed the -b.
= Note: Before you run/debug CAVE, make sure you get the following text
in the EDEX Request output, to show that EDEX is ready:

*Ahhkkhkkhkhkhkkhkkhkhkkhkkhhkkhhhkkhkhhkhkhhkhkkhhkhkkihkhkkihhhkkihhkkihhkkiihkiihkkiiikk

* EDEX ESB is now operational *

*hhkkhkkhkhkhkkhkkhkhkkhkkhhkkhkhhkkhkkihkkhkkhhkhkkhhkhkkihkhkkihhkkihhkkihhkkikihkkiikiiikk

o If you are using a Remote EDEX Server/standalone box, set up a mount point to
the hdf5 directory.
. Note: The EDEX instances, Qpid, Postgres, and Httpd-Pypies

must be running on the Remote EDEX Server/Standalone machine
you will connect to.
= su - (Switch to the root user so you can create a directory at /)
* mkdir /test-data (make a directory to mount to)
* chmod user:group /test-data (Change the user and group of the
directory to the debugging user)
* mount edex-machine:/awips2/edex/opt/data/hdf5 /test-
data (mount awips-devl:/awips2/edex/opt/data/hdf5 /test-data)
= Note: You will not have to do this every time. You will need to remount
if the EDEX-machine is restarted, if EDEX is redeployed to it, or if
your ADE machine is rebooted (or you log out).

= Note: If you receive a Project RPC Error you may need to run service
nfs restart as root and try again.

e  Start AlertViz in Eclipse.

° Note: As of R1G1-3, by default you must start Standalone AlertViz
before starting CAVE. CAVE will no longer start its own AlertViz, unless
it is set up specifically to do so.

° Note: Standalone AlertViz will not start unless it can connect to the
EDEX Request service.

e If this is the first time running AlertViz:

= In Eclipse, in the Java Perspective, expand the project
com.raytheon.uf.viz.product.alertviz

= Right click on alertviz.product and select Run As->1 Eclipse
Application. This will have errors, but will set up most of what is needed
in a configuration.

= Assoon as you start to see error/warning/info messages in the Console tab
or get the Connectivity Preferences Dialog, you can stop it by hitting the
red box icon next to the Console tab.

= Right click on alertviz.product again and select Run As->Run
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Configurations...

In the Run Configurations Dialog, alertviz.product should be selected
in the right pane under Eclipse Application.

Select the Configuration tab.

Make sure the Use an existing config.ini file as a template radio button is
selected.

Click the Workspace... button.

Expand com.raytheon.viz.product.awips and select config.ini. Then
click the OK button.

Click the Apply button.

Click the Close button.

o Start CAVE in Eclipse.
e If this is the first time running CAVE:

In Eclipse, in the Java Perspective, expand the project
com.raytheon.viz.product.awips (There may also be a
com.raytheon.viz.product.developer — developer.product)
Right click on awips.product and select Run As->1 Eclipse Application.
This will have errors, but will set up most of what is needed in a
configuration.
e If you receive an error like this:
Unrecognized option: -Xt
Error: Could not create the Java Virtual Machine.
You should right click on developer.product instead of
awips.product and select Run As->1 Eclipse Application
As soon as you start to see error/warning/info messages in the Console tab
(after you see the CAVE splash screen) or get the Connectivity
Preferences Dialog, you can stop it by hitting the red box icon next to the
Console tab.
Right click on awips.product again and select Debug As->Debug
Configurations...
In the Debug Configurations Dialog, awips.product should be selected
in the right pane under Eclipse Application.
Select the Configuration tab.
Make sure the Use an existing config.ini file as a template radio button is
selected.
Click the Workspace... button.
Expand com.raytheon.viz.product.awips and select config.ini. Then
click the OK button.
Click the Apply button.
Click the Close button.

e Start the Debugger.

e Right click on awips.product and select Debug As -> Debug
Configurations...
e Make sure awips.product is selected and click Debug.
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= Alternatively:
e Click the dropdown arrow next to the Debug button (bug icon) in
the toolbar and select awips.product.

e Open the Debug Perspective:

= You may get a popup message asking if you want to switch to the Debug
perspective (when starting a Debug session). If you get this message, just
click Yes.

= If this is the first time opening the Debug Perspective, click the Open
Perspective icon (box with a plus sign) in the upper right corner and
select Debug (with a bug icon) from the dropdown menu.

= Otherwise, in the upper right corner, click Debug (icon with a bug).

° Note: You should test your changes each time you change CAVE
code (using this procedure). Generally, CAVE code is in the project whose
name starts with com.raytheon.viz (or com.raytheon.uf.viz). CAVE does
utilize some EDEX code, especially the code in
com.raytheon.edex.common.

e  Verifyor Set your CAVE Preferences:
. Note: When you first open CAVE (no saved caveData), the
Localization may need to be set. You may get a Connectivity
Preferences popup window with the message: “Error: Unable to
connect to localization server.”
e Set the Localization Server from:
o http://localhost:9581/services (for a local EDEX)

OR

o http://edex-server:9581/services (http://awips-
int1:9581/services) (for a Remote EDEX)
e Set Site to OAX (the desired Site ID).
e Click Validate. The Localization Server text box should change
from red to white if CAVE can connect to the server.
e Click OK.

. Note: When you first open CAVE, you may get an error in
AlertViz — “Error setting up menu item
com.raytheon.uf.viz.core.exception.VizException: Undefined
variable ‘1d0’”. (This may be due to an incorrect Server Data
Directory.)

Select CAVE->Preferences.

Select Paths.

e Verify that the Share Directory is set to
0 /awips2/edex/data/share

Select Hydro Apps.
e Verify that the Database Connection String is set to
0 Jjdbc:postgresql://localhost:5432/hd _ob83oax
?user=awipsé&password=awips (for a local EDEX)

OR
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0 Jjdbc:postgresql://db-machine-
name:5432/hd_ob83ocax?user=awipsé&password=aw
ips (for a Remote EDEX)

= Select Localization.
e Verify that the Site is set to Site (OAX).
e Verify that the Localization Server is set to
o http://localhost:9581/services (for a local EDEX)

OR

o http://edex-machine:9581/services (http://awips-
dev1:9581/services) (for a Remote EDEX).
= Select Performance.
e Verify that the Video Card Texture Cache Size is set to 128MB.
= Click the OK button.
= If you made any changes to preferences (such as Localization), you will
need to close CAVE (stop debugging) and reopen it (start debugging)
using the same method as above. You do not need to restart AlertViz.
. Note: Changes to the RadarServer are the only preferences (at this time)
that do not require a restart of CAVE.
Note: Your preferences are saved in /home/user/caveData directory but
do not take effect until you restart CAVE. Closing the debugger
will not prevent them from being saved.

e  Start Running/Debugging
= Put a breakpoint in your code and make the correct selections in the
CAVE GUI to hit the breakpoint. Then step through the code.
= Example:

e Put a breakpoint in the paintinternal () method of
com.raytheon.viz.core/src/com/raytheon/viz/core/topo/
TopoResource.java.

e To hit the breakpoint, in your CAVE debug session select Maps-
>Hires TOPO Image.

0 Note: If you did not install the TOPO Pack with
EDEX (or if you did not set it up properly), you will
get the error “error creating tile” (caused by a
FileNotFoundException).
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